关于im-server社区版部署一直连接中问题

宇文花荣 4月前 132

一直显示链接中,不知道怎么回事

最新回复 (8)
  • x86 4月前
    引用 2
    请跟着这儿,一步步排查:

    https://docs.wildfirechat.cn/faq/server/q1.html
  • 宇文花荣 4月前
    引用 3
    您好,我排查了,没发现问题
  • 宇文花荣 4月前
    引用 4
    1.检查server.ip正确
    2.检查安全组和防火墙是否将1883,80开放。已经开放
    3.http://localhost/api/versio
    {
           "tags":"null",
           "branch":"null",
           "dirty":"null",
           "remoteOriginUrl":"null",
           "commitId":"null",
           "commitIdAbbrev":"null",
           "describe":"null",
           "describeShort":"null",
           "commitUserName":"null",
           "commitUserEmail":"null",
           "commitMessageFull":"null",
           "commitMessageShort":"null",
           "commitTime":"null",
           "closestTagName":"null",
           "closestTagCommitCount":"null",
           "buildUserName":"null",
           "buildUserEmail":"null",
           "buildTime":"null",
           "buildHost":"null",
           "buildVersion":"null",
           "runTime":966
    }
    4.检查客户端配置是否正确  正确
  • 宇文花荣 4月前
    引用 5
    这些我都检查了,您看下

  • x86 4月前
    引用 6
    是否用了自定义端口的 SDK,如果是自定义端口的 SDK 的话,im-server 里面,需要将 80 端口改成你们自定义的端口,然后访问 http://{ip}:{端口}/api/version 进行验证
  • 宇文花荣 4月前
    引用 7
    {
           "tags":"null",
           "branch":"null",
           "dirty":"null",
           "remoteOriginUrl":"null",
           "commitId":"null",
           "commitIdAbbrev":"null",
           "describe":"null",
           "describeShort":"null",
           "commitUserName":"null",
           "commitUserEmail":"null",
           "commitMessageFull":"null",
           "commitMessageShort":"null",
           "commitTime":"null",
           "closestTagName":"null",
           "closestTagCommitCount":"null",
           "buildUserName":"null",
           "buildUserEmail":"null",
           "buildTime":"null",
           "buildHost":"null",
           "buildVersion":"null",
           "runTime":985
    }
    这个是验证结果
  • 宇文花荣 4月前
    引用 8
    我用的uniapp,插件已经更换了
  • x86 4月前
    引用 9
    宇文花荣 我用的uniapp,插件已经更换了
    插件用的是什么端口?

    http://{ip}:{插件所用的端口}/api/version 有响应吗?
返回