iOS集成编译报错 脚本执行错误

zx 5月前 177

 我是iOS开发 我正在集成野火im 目前我遇到几个问题卡住了我的进度 我希望得到相关的技术支持。

我做了那些集成步骤: 1、下载了iOS源码 使用Xcode14.3.1 编译代码 打开ios-chat-master文件 双击了ios-chat.xcworkspace 修改WFCConfig.m文件中的IM_SERVER_HOST和APP_SERVER_ADDRESS 然后编译报错 报错截图已上传附件图片

 2、运行ios-chat空间目录下的release_libs.sh脚本 这个步骤 我是将这个文件拖进mac命令终端 点回车健 然后等待编译完成后也出现了错误 报错文件我也保存为txt 上传到附件
上传的附件:
最新回复 (3)
  • HeavyRain 5月前
    引用 2
    协议栈用的是xcode15编译的,所以xcode14是不行的,请升级到15编译。如果想用旧版本的xcode编译,请使用xcode15发布之前的代码
  • zx 5月前
    引用 3
    你好那个版本是兼容 xcode 14.3的
  • HeavyRain 5月前
    引用 4
    我们没有记录,你可以查一下xcode15正式发布的时间,然后从代码的git记录中找到这个时间之前的代码
返回