jssdk移入uni-app vue3版本中,dsbridge无法支持

carolinetanxin 1月前 111

将jssdk引入自身uni-app vue3版本的项目中,会报错require is not defined.

网上查教程 改成import("dsbridge"),会报错bridge().register is not a function。请问有办法让该文件能够引入生效的方法嘛?

最新回复 (7)
  • HeavyRain 1月前
    引用 2
    这个问题不属于野火的范围,我们没有办法解决,请从网上查查或者他们有没有官网或者开源主页去问一下他们
  • x86 1月前
    引用 3
    是需要使用开放平台?

    最新 demo 已经支持开放平台了,请参考下。
  • carolinetanxin 1月前
    引用 4
    HeavyRain 这个问题不属于野火的范围,我们没有办法解决,请从网上查查或者他们有没有官网或者开源主页去问一下他们
    好吧 谢谢老师!
  • carolinetanxin 1月前
    引用 5
    x86 是需要使用开放平台? 最新 demo 已经支持开放平台了,请参考下。
    是使用开放平台的demo的,就是将jssdk文件包引用到uni-app vue3版本的时候,发现require("dsbridge")不支持,想问问老师们有没有遇到过这种情况的~
  • x86 1月前
    引用 6
    你看最新的uni-chat,没有用到dsbridge,已经支持开放平台,只是不是vue3而已
  • carolinetanxin 1月前
    引用 7
    x86 你看最新的uni-chat,没有用到dsbridge,已经支持开放平台,只是不是vue3而已
    嗯嗯,老师我表述有误,uni-chat的代码是没问题的,我说的也不是uni-chat项目,而是open-platform项目和daily-report项目下,src/jssdk
    /util.js 文件里的 dsbridge 的引用。
  • x86 1月前
    引用 8
    不升级,直接跑,有问题吗?

    这好像不是代码的问题,是 uni-app vue3 配置的问题
返回