win本地部署后,App使用code登录,提示 信息 登录失败!

sonppy 2月前 192

本地服务器部署成功,api/version 有回参, 8888端口也是OK

但是手机用code 66666 登录后吐司 登录失败!

debugApp端,返回的code是410

最新回复 (11)
  • HeavyRain 2月前
    引用 2
    debug一下appserver,appserver是开源的,有源码
  • sonppy 2月前
    引用 3
    appserver 中debug的方法是下面这个吗?
        @PostMapping(value = "/login", produces = "application/json;charset=UTF-8")
        public Object login(@RequestBody LoginRequest request) {
            return mService.login(request.getMobile(), request.getCode(), request.getClientId(), request.getPlatform() == null ? 0 : request.getPlatform());
        }

    但是我移动端登录了,没有走appserver中这个login方法
    移动端debug还是报410
  • HeavyRain 2月前
    引用 4
    1,先试试移动端退出登录,然后重新登录试一下
    2,应用服务有个配置如下,如果不支持https要把这个开关设置为false


    # 是否支持SSL,如果所有客户端调用appserver都支持https,请把下面开关设置为true,否则为false。
    # 如果为false,在Web端和wx端的appserve的群公告等功能将不可用。
    # 详情请参考 https://www.baidu.com/s?wd=cookie+SameSite&ie=utf-8
    wfc.all_client_support_ssl=false
  • sonppy 2月前
    引用 5

    IMServer和AppServer成功启动,截图见附件

    AppServer 中 wfc.all_client_support_ssl=false 这个值是false,

    在登录的时候,我用Fiddler抓包截图如下,APP还是登录失败,debug410状态码,还有哪些地方配置的不对吗?

    上传的附件:
  • HeavyRain 2月前
    引用 6
    是不是客户端上应用服务的地址写的不对啊,应用服务就是3楼的那个接口,如果点击登录就应该走的那个接口。是不是你们修改代码了?正常情况下只修改配置问题就行了,如果修改了,尝试用没有修改的版本进行验证,确认没有修改代码的情况下,如果还是不行,请提供服务器信息及客户端配置
  • sonppy 2月前
    引用 7

    没有修改

    上传的附件:
  • HeavyRain 2月前
    引用 8
    你试试下载最新的im服务/app服务/android客户端源码,然后重新部署,我们刚测试过了,用最新的版本都是可以连上的
  • sonppy 2月前
    引用 9

    好的,好的,感谢

    你们测试部署环境也是在win上吗?还是在linux上?

  • sonppy 2月前
    引用 10
    现在可以正常登陆了,之前android-chat 源码不是最新的,现在换了最新的可以正常登陆了
  • HeavyRain 2月前
    引用 11
    sonppy 好的,好的,感谢 你们测试部署环境也是在win上吗?还是在linux上?
    建议用linux
  • sonppy 2月前
    引用 12
    好的,在win上部署只是测试基础功能。
    正式测试部署会放在linux上。
    感谢!
返回